Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 18, 2024 - 22:00 EST
Scheduled
We will be upgrading our software to the latest version - during this maintenance period the myImpactPage.com and admin.betterimpact.com portals will be unavailable for approximately 5-10 minutes.
This update will begin at the following local times:
New York, USA: Monday, November 18, 2024 10:00 PM London, UK: Tuesday, 19 November 2024 3:00 AM Sydney, Australia: Tuesday, 19 November 2024 2:00 PM
Posted Nov 14, 2024 - 14:58 EST
This scheduled maintenance affected: Web Application.